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1. Introduction 
iMediaTrans is an online resource which comprises a fully integrated toolset that is used for subtitling or 

captioning videos. This helps the clients to meet the vendors/freelancers to discuss the project. In 

iMediaTrans all the tools are integrated on the web and the clients have full visibility of the subtitling 

projects that are being done. 
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2. Accessing iMediaTrans 

2.1 How to Register as a New User 
The user has to register with iMediaTrans before the user can login. 

To register 

1. Enter the URL (www.imediatrans.com) in the address bar of the browser. The following page is 

displayed. 

 

2. Click Start Now. The following page is displayed. 

http://www.imediatrans.com/
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3. Enter the first name of the user in the First Name field. 

4. Enter the last name of the project in the Last Name field. 

5. Enter a valid email address in the Email field. 

6. Enter the password to login in the Password field. 

7. Re-enter the password to confirm in the Confirm Password field. 

8. Enter the contact number of the user in the Contact Number field. 

9. Enter the company/organization to which the user belongs in the Company or Organization field. 

Note: This is not mandatory a mandatory field. 

10. Select the country of residence from the Country of Residence field. 

11. Click Register. The following page is displayed and a welcome email is sent to the registered email 

address. 
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12. Click Complete Your Registration link in the email to complete the registration process. 

 

13. The homepage is displayed.
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2.2 How to Login to iMediaTrans 
1. Enter the URL (www.imediatrans.com) in the address bar of the browser. The following page is 

displayed. 

 

2. Click Already a User? The following page is displayed. 

 

3. Enter the registered email address in the Email field. 

4. Enter the password to authenticate in the Password field. 

http://www.imediatrans.com/
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5. Click Sign In. 

2.2.1. How to Recover the Password 
1. From the Login page, click Forgot your password? The following page is displayed. 

 

2. Enter the registered email address in the Email field. 

3. Click Send Password Rest Link. This sends email with a reset link to the registered email address. 

 

4. Click the link in the email. The following page is displayed. 
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5. Enter the new password in the New password field. 

6. Re-enter the new password in the Verify password field. 

7. Click Submit to login.
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3. Sections in iMediaTrans 

3.1 New Uploads 
The New Uploads section displays the videos uploaded on iMediaTrans. You can select more than one 

video simultaneously and create projects. 

1. Once you login successfully, go to New Uploads. The following page is displayed. 

 

2. You can select more than one file simultaneously as shown. 

 

3.  Once selected, you can click Create Project to create a new project. The following page is displayed. 

 

4. Refer Creating the Project for more information
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3.2 All Projects 
The All Projects section displays all the available projects. 

1. Once you login successfully, go to All Projects. The following page is displayed. 

 

2. Click  to minimize the tree structure and displays the Spreading button as shown. 

 

Note: You can toggle the  /  button to minimize or expand the projects. 

3.2.1. Searching the Projects Section 
You can use the Search function to locate a specific project / video. 

1. Select the required search criteria (Video name / Project name) from the dropdown list. 
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2. Enter the name of the video / project in the field. 

3. Click Search. The videos / projects matching the search criteria are displayed. 

 



My Projects    

iMediaTrans User Manual   10 

3.3 My Projects  
The My Projects section displays all the list of projects assigned to you as well as projects created by 

you. 

 

3.3.1. Exporting the File 
This option enables you to export the file to a different format. 

1. Go to My Projects and click Export. 

 

2. The following list is displayed. 

 



My Projects    

iMediaTrans User Manual   11 

Note: The project should be "COMPLETE" in order to be exported, else the "Export" button will not be 

displayed. 

3. Select the required format from the list. 

4. This downloads the file in the selected format.
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3.4 Root 
The Root enables you to create folders, which helps to classify the videos / projects. 

1. Click the Root folder. The following page is displayed. 

 

3.4.1. Creating a Folder 
1. Click the Add Folder. The following popup window is displayed. 

 

2. Enter the name of the folder in the Folder Name window. 

3. Select the department from the Select Department dropdown list. 

4. Click Create. This creates the folder. 

 



Root    

iMediaTrans User Manual   13 

Refer to Uploading Videos, Creating Project and Spreading for more information. 

Note: To move the videos / files from the All Projects / My Projects sections, drag and drop the videos / 

files to the required folder in the Root on the left panel. 

 

3.4.2. Modifying the Folder 
1. Click to open the required folder. Click Settings button. The following popup window is displayed. 

 

2. Modify the required details and click Save Changes. 

3. To delete the folder, click Delete. The confirmation popup window is displayed. 
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4. Click Delete to delete the folder
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4. How to Start a New Project 

4.1 Uploading Video 
This option enables you to upload a video for the subtitling process. You can upload the video from the 

servers or through the FTP. 

To upload the video 

1. From the homepage, click Upload Video dropdown list. The following menu is displayed. 

 

2. Select the required method to upload the video. 

 Upload using server 

i. From the menu, select the required server. The following page is displayed. 

 

ii. Click Add Videos. The following popup window is displayed. 
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Note: You can also drag and drop the files to the area in green color to upload the video. 

iii. Browse to select the required video file and click Open. 

 Upload using FTP 

i. From the menu, select Upload by FTP. The following page is displayed. 

 

ii. Connect to the FTP using the details to upload the video. 

Note: iMediaTrans support all video formats. Once uploaded iMediaTrans converts the video to 

streaming format. This helps the translators to work directly on the video and does not require any 

additional software to play the video. 
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3. The uploaded video is displayed in the New Uploads section as shown. 

 

Note: You can click the  icon adjacent to the uploaded video to play the video.
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4.2 Creating a Project From the Project List 
1. Select the required video and click Create Project button corresponding video. The following page is 

displayed. 

 

2. Enter the due for the project in the Due Date field. 

3. Select the time from the dropdown list. 

4. Select the language from the Language dropdown list. 

5. Select the style from the Style dropdown list. 

6. Enter the name of the project from the Project Name field. 

7. Enter the name of the user to assign the project from the Assignment field. 

8. If the user is not registered and would like to access iMediaTrans, enter the email address field in 

the Enter an email address to allow access to iMediaTrans without registering field. 

9. Click Create to create the project.
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4.3 Assigning the Project 
This option enables to create new projects which can be shared with the translators. 

To create the project 

1. From the homepage, go to New Uploads / All Projects section. 

2. Select the required video by selecting the corresponding checkbox. 

3. Click Create Project. The following popup window is displayed. 

 

Note: You can also click the Create Project button corresponding to the video to create a project. 

 

4. Select the language and the style from the Language / Style dropdown list. 
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5. Enter the name of the user to whom the project is assigned in the Assignment field. Alternatively 

you can enter the email address of the user in the Email address field. 

 

6. Click the Due Date field to select the date for completing the project from the popup calendar. You 

can select the time from the corresponding dropdown list. 

Note: If the time is not specified, by default 23:59:00 (11:59:00 pm) is assigned. 

 

7. Click Create. This creates the project as shown. 

 

8. You can click the  icon to send an email alert to the assigned user. 
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4.4 Creating a Pivot Project  
1. Click to open the required project. The following page is displayed. 

 

2. Go to Management > Create Pivot Translation. The following popup window is displayed. 

 

3. Select the target language from the Language dropdown list. 

4. Select the required style from the dropdown list. 

5. Enter a name for the project in the Name field. 

6. To lock the time stampings, select the Timecode Lock checkbox. This prevents the user working on 

the project from modifying the time stamp. 

7. From the Enable Columns section, select the required checkboxes. 

 Timecode in – Selecting this checkbox enables the user to view the Timecode In column. 
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 Timecode out - Selecting this checkbox enables the user to view the Timecode Out column. 

 Memo - Selecting this checkbox enables an additional column where the user can enter the 

notes. 

8. Click Create. This creates the project as shown. 

 

 

9. Click the Due Date button to select a due date for the project from the calendar. Refer Modifying 

the Due Date for more information. 

10. Click the  icon to assign the user for this project. 

11. The following page is displayed when the user views the project. 

 

Note: The assigned user cannot modify the timestamp In and Out column if the Timecode Lock checkbox 

was selected.
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4.5 Modifying the Due Date 
1. To modify the due date for the project, click the date corresponding to the project from the Date 

column. The following popup window is displayed. 

 

2. Select the required date from the calendar. 

3. Select the required time from the dropdown list. 

4. Click Save Changes. This updates the due date
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5. How to Work on the Assignment 
1. Click the link in the received email as shown. 

 

2. The following page is displayed. 

 

3.  You can click the dropdown to select the speed of the playback. 
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Note: The buttons beneath the movie player can also be used to control the speed of the playback. 

4. To hide the waveforms, click Hide waveform. 

5. To add attachment, click Attachments. The following page is displayed. 

 

1. Click Add Files. The following popup window. 

 

2. Select the required file and click Open. This uploads the files. 

Note: You can also drag and drop the file to be uploaded into the “Drop files here” to upload. 
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3. When more the one attachment is added, the number of attachments are displayed adjacent to the 

Attachment link as shown. 

 

4. To view the list of attachments, click the Attachments link. The following page is displayed. 

 

5. To delete the attachment, click Delete corresponding to the attachment to be deleted. 

6. To add a comment, click Add Comment. The following popup window is displayed. 

 

7. Enter the comment and click Save. The following popup window is displayed. 
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8. Click Close to close the Comments window. The number of comments is displayed adjacent to the 

Comments link as shown. 
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5.1 Video Player Control Keys 
The following are the control keys available in the video player. 

 - Clicking this button plays the video. 

 - Clicking this button forwards the video by one second. 

 - Clicking this button rewinds the video by one second. 

 - Clicking this button forwards the video by the seconds specified in the box. 

 - Clicking this button forwards the video by the seconds specified in the box. 

 - Clicking this button takes you to the end of the video. 

 - Clicking this button takes you to the beginning of the video. 

 - Enables you to align the subtitles used in the video. 

5.1.1. Positioning the Subtitle 
This option is used when there are graphic texts on screen and the caption/subtitle text overlaps with 

them. In order to avoid overlapping with the graphics, the subtitles are re-positioned using the 

alignment buttons. 

1. Once the subtitle is entered, click the  buttons to position the subtitle. 

Note: The alignment keys are not displayed if the Style used for the project does not have the feature. 

2. To left align the subtitle text, click the  icon. The subtitle is displayed as shown. 
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3. To center align the subtitle text, click the  icon. The subtitle is displayed as shown. 

 

4. To right align the subtitle text, click the  icon. The subtitle is displayed as shown 
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5. You can click the  or the  button to move the subtitle up or down. Based on the position of 

the subtitle, the value is changed in Position column as shown. 

  

Note: You can also copy the positional data (text) and paste it to other subtitles to apply the same 

position to multiple subtitles.
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5.2 Command Buttons 
The following are the command buttons: 

 -  Clicking this button plays the video for the section. 

 - Clicking this buttons puases the video. 

 - Clicking this button enables the users to add comments. 

 - Clicking this button enables the users to add new rows. 

 - Clicking this button enables the users to split rows. 

 - Clicking this button enables the users to merge rows. 

 - Clicking this button enables the users to delete rows. 

5.2.1. Adding Comment 

1. Select the required cell from the subtitle column and click the  icon. The following popup 

window is displayed. 

 

2. Enter the required comment in the Comment field. 

Note: The field can be used as a point of communication between the project manager and subtitler or 

between a translator and reviewer. 

3. Click Save. The comment is saved as shown. 
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4. The line with the comments will be marked with a small Red triangle as shown. 

 

5. To view the existing comments, click the  icon from the required cell. The following popup 

window is displayed. 

 

6. To delete the comment, click the  button corresponding to the comment. 

7. Click Close to close the window. 
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5.2.2. Inserting a Row 

1. Select the required cell from the subtitle column and click the  icon. This inserts a row as shown. 

 

Note: You cannot insert a timecode that is smaller than the previous out-time or bigger than the next in-

time. To enter the timecode in the new row, delete the out-time from the previous row. 

5.2.3. Merging the Rows 

1. Move the mouse over the cell to be merged and click the  icon. 

 

2. This merges the row as shown. 

 

Note: When merging the rows, the time stamping in the Out column, the duration, the text in the 

subtitle column and the values in the length column are merged. 

5.2.4. Splitting the Rows 

1. Select the required cell from the subtitle column and click the  icon. This splits the row as 

shown, but the same translation text will be copied to the new row. 
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Note: The text in the subtitle column has to be modified when splitting the rows. 

5.2.5. Deleting the Row 

1. Select the required cell from the subtitle column and click the  icon. This deletes the row. 
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5.3 Submitting the Assignment 
1. Once the project is completed, click Save. 

2. Go to Management > Complete. The following popup window is displayed. 

 

3. Click Yes, I want to submit the assignment. The following popup window which shows the rating is 

displayed. 

 

 

Note: A project completion email notification is sent to the project manager. The project manager can 

click the link in the email to review the assignment. 
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5.4 Edit Menu 

5.4.1. Undo 
This option enables you to revert an action that is performed by you. 

1. Go to Edit > Undo. This reverts the action that is performed by you. 

5.4.2. Redo 
This option reverts the undo action. 

1. Go to Edit > Redo. This reverts the undo action that is performed by you. 

5.4.3. Timecode Shift 
This option enables you to move time codes slightly, when there is a need to sync subtitles against an 

edited video which differs from the original video.  

1. Select the required In or the Out Timecode. 

2. Go to Edit > Timecode shift. 

 

3. The following popup window is displayed. 

 

4. Select the “+” or “–“ option  

5. Enter the hours, minutes and seconds. 
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6. Click Shift. This changes the In and the Out timestamp accordingly. 

5.4.4. RTL Convert 
This option is useful when the translation is done to Middle Eastern languages such as Hebrew and 

Arabic which are written predominantly right to left. 

1. Select the required Subtitle cell. 

2. Go to Edit > RTL Convert. 

 

3. This converts the direction of the written text from right to left. 

5.4.5. Clear All Timecodes 
This option enables you to easily clear all time codes which are already stamped. 

1. Go to Edit > Clear All Timecodes. 

 

2. This clears all the timestamp. 
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5.4.6. Preferences 
This option enables you to define the insertion latency as well as fine tune each of the time code 

(moving forward/backwards). 

1. Go to Edit > Preferences. 

 

2. The following popup window is displayed. 

 

3. Enter the insertion latency of the timecode in the Timecode Insertion Latency field. This enables the 

user to stamp the In Timecode earlier. For e.g., setting an insertion latency of 0.5 seconds, stamps 

the In Timecode 0.5 seconds earlier than the real time. 

Note: By default the Timecode Insertion Latency is set at 0.5 seconds. 

4. Enter the time for the moving backward/forward in the Moving Step field. This time defines how 

much to move forward or backward when the  or the  button is clicked. 

5. Click Save Changes to save the changes made.
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5.5 Find Menu 

5.5.1. Go to Line 
1. Go to Find > Go to Line. The following popup window is displayed. 

 

2. Enter the required line number in the Line number field. 

3. Click OK. This highlights the line as shown. 

 

5.5.2. Find 
1. Go to Find > Find. The following popup window is displayed. 

 

2. Enter the search term in the field and click OK. 

3. The term matching the search term is highlighted as shown. 
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5.5.3. Find and Replace 
1. Go to Find > Find and Replace. The following popup window is displayed. 

 

2. Enter the term to be replaced in the Find field. 

3. Enter the term to be replaced with in the Replace With field. 

4. Click Replace All. This replaces all the term with the new term.
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6. Stamping the Time Code 
6.1.1. Time Coding Using Hotkeys 
1. Select the cell in the first row as shown. 

 

2. Press Shift + Enter on hearing the dialogue. This captures the starting time of the dialogue. 

 

3. Press Shift + Enter when the next dialogue starts. This captures the out time in the Out column and 

the In column in the next row. 

 

Note: You can go to Help > Hotkeys to view the list of available hotkeys. 

4. Repeat the above step to capture the In and Out time stampings for the video.  
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Note: If there is no dialogue, press the Enter key from the keyboard to modify the Timecode of the 

current cursor position. There will be a gap between the Out and the next In time, according to the Style 

that is set for the project. 

5. To transcribe the subtitle, select Subtitle column corresponding to the In and Out time stampings. 

 

6. Click the  button to play the audio in that section and enter the text. 

 

 

7. When the video is played, the text entered in the subtitle column is displayed as shown. 

 

6.1.2. Time Coding using the Buttons 
You can also stamp the time coding using the button controls placed near the menu. 
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1. Click the  button to play. 

2. Click the  button at the end of the sentence to stamp the In and Out time as shown. 

 

Note: By default the duration between the In and the Out time is calculated to be 2 seconds. You can 

modify the In time as required. 

3. To manually stamp the In and the Out time, click the  at the start of the dialogue and click  

at the end of the dialogue. 

4. To hide the waveforms, click Hide waveform.



Settings    

iMediaTrans User Manual   44 

7. How to Manage the Project 

7.1 Settings 
The Settings section provides you the options to modify the preferences, add attachments or delete the 

files. This option is displayed when the  icon is clicked. 

 

7.1.1. Preferences 

1. Click the  icon and select Preferences from the dropdown. The following window is displayed. 

 

2. Modify the required details and click Save Changes. 

3. To archive the settings, click Archive. 

7.1.2. Attachment 
The Attachment function can be used to attach reference materials for translation projects such as 

attaching source scripts or glossary. 
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9. Click the  icon and select Attachment from the dropdown. The following window is displayed. 

 

10. Click Add Files. The following popup window. 

 

11. Select the required file and click Open. This uploads the files. 

Note: You can also drag and drop the file to be uploaded into the “Drop files here” to upload. 

7.1.3. Delete 

1. Click the  icon and select Delete from the dropdown. The following confirmation window is 

displayed. 
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2. Click OK to delete.
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7.2 File Menu 

7.2.1. Versions 
Versions are files that are saved automatically. The user can go back to the previous version or use it to 

retrieve the last saved data in case of any loss of data. 

1. Go to File > Versions. This displays the list of available versions. 

 

2. You can click the version link to view the file. 

7.2.2. Exporting the File 
1. Go to File > Export. The list of available formats is displayed. 
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2. Select the required format to export the file. 

7.2.3. Importing the File 
1. Go to File > Import. The following popup window is displayed. 
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2. Click Choose File. The following popup window is displayed. 

 

3. Browse to select the required file and click Open. 

4. Click Import.
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7.3 Management Menu 

7.3.1. Completing 
Refer Submitting the Assignment for more information. 

7.3.2. Creating a Pivot Transition 
Refer Creating a Pivot Transition for more information. 

7.3.3. Creating a Proofreading 
1. Go to Management > Create Proofreading. The following popup window is displayed. 

 

2. Select the target language from the Language dropdown list. 

3. Select the required style from the dropdown list. 

4. Enter a name for the project in the Name field. 

5. To lock the time stampings, select the Timecode Lock checkbox. This prevents the user working on 

the project from modifying the time stamp. 

6. From the Enable Columns section, select the required checkboxes. 

 Timecode in – Selecting this checkbox enables the user to view the Timecode In column. 

 Timecode out - Selecting this checkbox enables the user to view the Timecode Out column. 

 Memo - Selecting this checkbox enables an additional column where the user can enter the 

notes. 

7. Click Create Proofreading. This creates the proofreading project as shown. 
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8. The following page is displayed when the Proofreading project is opened. 

 

7.3.4. Proofreading a Project 
1. Open the required proofreading project. The following page is displayed. 
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2. Modify the content as required in the Subtitle (Translation) column. 

3. Any changes made are highlighted in green color and is displayed in the Compare column as shown. 

 

4. This serves as a point of reference for the translator. 

7.3.5. Duplicating a Project 
1. Go to Management > Duplicate Project. The following popup window is displayed. 

 

2. Click Duplicate. This duplicates the project as shown. 

 

3. Once duplicated, you can modify the Due Date, assign it to user or change the project settings. 
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7.4 View Menu 

7.4.1. Zoom 
This option enables you to zoom the screen. 

1. Go to View and select the required zoom level. 

 100% - Zooms the screen 100%. 

 150% - Zooms the screen 150%. 

 Full Screen - Zooms the screen full size. 

2. Based on the zoom level selected, following screen is displayed. 

100% 
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150% 

 

Full Screen 

 

7.4.2. Command Buttons 
This option enables you to show / hide the command buttons in the source/subtitle column. 

1. Go to View > Command buttons. This hides the command buttons as shown. 
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2. To view the command buttons, go to View > Command buttons. This displays the Command 

buttons as shown. 

 

7.4.3. Duration 
This option enables you to show / hide the Duration column. 

1. Go to View > Duration. This displays the Duration column as shown. 
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2. To hide column, go to View and select Duration. 

7.4.4. Memo 
This option enables you to show / hide the Memo column. 

1. Go to View > Memo. This displays the Memo column as shown. 
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2. To hide column, go to View and select Memo. 

7.4.5. Timecode 
This option enables you to show / hide the Timecode columns. 

1. Go to View > Timecode. This displays the Timecode column as shown. 

 

2. To hide column, go to View and select Timecode. 

7.4.6. Source Language 
This option enables you to show / hide the Source Language column. 

1. Go to View > Source Language. This displays the Source Language column as shown. 
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2. To hide column, go to View and select Source Language. 

7.4.7. Compare Subtitle 
This option enables you to show / hide the Compare Subtitle column. This option is used for 

proofreading project, to show the translator where and how it has been edited. 

1. Go to View > Compare Subtitle. This displays the Compare Subtitle column as shown. 

 

2. To hide column, go to View and select Compare Subtitle.
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7.5 Share Menu 

7.5.1. Sharing View Only Version 
1. Go to Share > Share View Only Version. The following popup window is displayed. 

 

2. Copy and send the link to the required user. When the user clicks the link, the file is opened in a 

Read Only view. 

 

7.5.2. Sharing the Video Player 
1. Go to Share > Share Video Player. The following popup window is displayed. 
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2. Enter the email address in the Email address field. 

Note: You can share the video player to more than one user. To share it, enter the email address of the 

all users separated by a comma. 

3. Enter the password in the Password field. This is only an optional field. 

4. Click Send. The following popup window is displayed. 

 

5. Click OK. The email is received as shown. 
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8. How to Manage the Settings 

8.1 Schedules 
1. Once logged into iMediaTrans, click Schedules. The following page is displayed. 

 

2. From the dropdown list select the required schedule (Reg. Date / Due Date). 

3. Click the From field to select the from date from the calendar. 

4. Click the To field to select the to date from the calendar. 

5. Select the required filter (All, Working or Completed). 

6. Click Search. The schedules matching the criteria are displayed.
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8.2 Styles 

8.2.1. Creating New Style 
1. Go to Styles . The following page is displayed. 

 

2. Click Create. The following page is displayed. 

 

3. Enter the name of the style in the Template Name field. 

4. Click Create. This creates the template. 

Note: By default, the name of the template is displayed in the Template Name field. You can modify the 

name if required. 

5. Enter the required resolution of the screen in the Resolution field. 

6. Select the required FPS from the FPS dropdown list and enter the frame split in the Frame Split field. 

7. Enter the maximum length of the character / byte from the Maximum Length field and select the 

required option corresponding to the maximum length – Character / Byte. 
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8. Enter the maximum length per second in the Maximum Length / Sec field. 

9. Enter the minimum length per second in the Minimum Length / Sec field. 

10. Enter the minimum duration in seconds in the Minimum Duration (Sec) field. 

11. Enter the maximum duration in seconds in the Maximum Duration (Sec) field. 

12. Move the Safe Area X slider to select the safe area horizontally. 

Note: Moving the slider point on the left side increases/decreases the margin on the left hand side. 

Moving the slider point on the right side increases/decreases the margin on the right hand side. 

13.  Move the Safe Area Y slider to select the safe area vertically. 
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14. Select the required justification of the text from the Center Justification section. 

15. Select the Turning Closed Captioning On checkbox to turn on the closed captioning. 

16. Select the required font for the text. 

17. Slide the Font Size slide bar to select the size of the text. 
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18. Slide the Line Spacing slide bar to select the spacing between lines. 

19. Slide the Character Spacing slide bar to space between the characters. 

20. Select the checkbox corresponding to the required colors from the Available Colors section. The 

colors selected are applied to the fonts in the subtitle. 

Note: The Caption files are for hard-of-hearing. For files with different characters or background 

sounds/explanation, the subtitles will be distinguished by the color. 

21. Select the required positioning from the Allow Positioning section. 

Note: The alignment keys are not displayed if the Style used for the project does not have the feature. 
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22. To select a background, click Click to select background image.  

 

23. The following window is displayed. 
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24. Browse the required picture and click Open. This displays the background as shown. 

 

Note: This screen is similar to the live screen watched by the user. By using this screen, we can verify the 

location of the subtitles, the background looks, and check the screen resolution. 

25. Click Save to save the template. 



Styles    

iMediaTrans User Manual   68 

8.2.2. Modifying the Style 
1. Go to Styles. This displays the list of available templates. 

2. Click the name of the template to be modified. 

3. Make the required changes and click Save. 

8.2.3. Deleting the Style 
1. Go to Styles. This displays the list of available templates. 

2. Click the  icon corresponding to the template to be deleted. The confirmation message box is 

displayed. 

 

3. Click OK to delete.
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8.3 Billing 
This option enables the users to create billing for the nodes purchased. 

1. Click the user name and select Billing. 

 

2. The following page is displayed. 

 

3. Click Buy Nodes. The following popup window is displayed. Refer Pricing Plan for more information. 

 

4. Select the required number of nodes from the Nodes dropdown list. 
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5. Click PayPal check out. The following page is displayed. 

 

6. Enter the Email address and the PayPal password to login to pay for the nodes. 

7. If you want to pay using the debit or credit card, click the Pay with my debit or credit card link. The 

following page is displayed. 

a. Card Information 

 

b. Billing Information 
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8. Enter the card and billing information. 

9. Click Pay to pay for the nodes. 
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8.3.1. Viewing the Billing Invoice 
1. Click the user name and select Billing. 

2. The following page is displayed. 

 

3. Click the Date link for which you would like to see the invoice. The following page is displayed. 



Departments    

iMediaTrans User Manual   73 

8.4 Departments 
1. Click the user name and select Departments. 

 

2. The following page is displayed. 

 

3. Click Create a Department. The following page is displayed. 

 

4. Enter the name of the department in the Department Name field. 

5. Enter the name of the user in the Manager field. This displays a list of names. 
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6. Select the required user to assign as the manager.  

7. Click Create. This creates the department and is displayed as shown. 

 

Note: You can click the name link in the Manager column to view the details of the user.
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8.5 Users 
This option enables you to create new users, invite users or send links to the users. 

8.5.1. Adding User 
1. Click the user name and select Users. 

 

2. The following page is displayed. 

 

3. Click Add User. The following popup window is displayed. 
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4. Enter the first name of the user in the First name field. 

5. Enter the last name of the user in the Last name field. 

6. Enter the valid email address of the user in the Email field. 

7. Enter the password in the Password field. 

8. Select the required checkboxes. 

 Activated – Selecting this checkbox, activates the user. 

 Video Upload Notification – Selecting this checkbox enables the users to receive 

notification during video upload. 

 Allow Exporting – Selecting this checkbox enables the users to allow exporting. 

 Department Manager – Selecting this checkbox enables the users to perform the role of a 

department manager. 

 Administrator - Selecting this checkbox enables the users to perform the role of the 

administrator. 

9. Select the required department from the Department dropdown list. 

10. Click Add user. 
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8.5.2. Inviting User 
1. Click the user name and select Users. 

 

2. The following page is displayed. 

 

3. Click Invite. The following popup window is displayed. 
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4. Enter the email address of the user to be invited in the Email field. 

5. Click Invite. 

8.5.3. Invitation Link 
1. Click the user name and select Users. 

 

2. The following page is displayed. 

 

3. Click Invitation Link. The following popup window is displayed. 

 

4. You can copy the link and paste it in an email message or you can also paste the link in a webpage. 
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8.5.4. Search 
This feature enables the users to locate specific information by selecting the search criteria. 

1. Click the user name and select Users. 

2. Select the search criteria from the dropdown list. 

3. Enter the search term in the field and click Search. 

 

4. The results matching the search criteria are displayed.
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8.6 Account Settings 
1. Click the user name and select Account Settings. 

 

2. The following page is displayed. 
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3. Modify the required details. 

4. Click Save Changes to update the account settings.
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8.7 Password 
1. Click the user name and select Password. 

 

2. The following page is displayed. 

 

3. Enter the current password in the Current password field. 

4. Enter the new password in the New password field. 

5. Re-enter the new password in the Verify password field. 

6. Click Save Changes to update the password.
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8.8 Pricing Plan 
This provides the various pricing plan options that are available with iMediaTrans. 

1. Click Pricing Plan. The following page is displayed. 

 

2. iMediaTrans provides the following types of plans: 

a. Basic Vimeo Video Hosting 

b. DRM Only Without CDN 

c. DRM With CDN 

Refer Pricing Plan for more information 

http://beta.imediatrans.com/plans

